App Outage
Incident Report for Pingboard
Postmortem

Pingboard experienced an extended period of downtime and performance issues from 3 AM CDT to 4 PM CDT on August 12, 2021. This was not a security breach and no customer data was obtained by the attackers – your organization’s data remains secure.

We apologize–we know our customers rely on Pingboard and were disappointed by the interruption. One of our key values at Pingboard is “be transparent”, and we’re committed to upholding transparency in every circumstance. In the spirit of that value, we’ve prepared a detailed report on what happened, what it means for you, and what we’re doing to improve. You can read the full details of that report here on our company blog.

Posted Aug 19, 2021 - 17:01 CDT

Resolved
Pingboard experienced an extended period of downtime and performance issues as result of a coordinated DDoS attack on our public sign-up and sign-in pages. This was not a security breach and no customer data was obtained by the attackers – your organization’s data remains secure.
Posted Aug 12, 2021 - 03:00 CDT